<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">

<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
	<meta name="format-detection" content="telephone=no">
	<meta name="theme-color" content="#db0300">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://www.zimbojam.com/xmlrpc.php">
		
	<title>Team Legacy Zw: Championing the Zim Hip Hop movement - Zimbo Jam</title>

<!-- Ads on this site are served by WP PRO Advertising System - All In One Ad Manager v4.7.2 - wordpress-advertising.com -->
<!-- / WP PRO Advertising System - All In One Ad Manager. -->

        <style>

            #newsletter-close {
                position: absolute;
                right: -10px;
                top: -10px;
                cursor: pointer;
            }
            #newsletter-popup-overlay {
                display: none;
                background:#000;
                position:fixed;
                top:0;
                bottom: 0;
                right: 0;
                left:0px;
                z-index:10000;
                cursor:pointer;
                opacity: .7;
                filter: alpha(opacity=70);
                -ms-filter:"progid:DXImageTransform.Microsoft.Alpha(Opacity=70)";
            }

            #newsletter-popup-container {
                display: none;
                position:fixed;
                top:0;
                bottom:0;
                right:0;
                left:0;
                z-index:11000;
            }

            #newsletter-popup{
                position: relative;
                margin: 100px auto;
                background-color:#fff;
                width: 510px;
                height: 410px;
                border: 3px solid #db0304;
                border-radius: 0px;
                box-sizing: content-box;
            }

            @media (max-width: 768px) {
                #newsletter-popup{
                    width: 90%;
                    margin: 30px auto;
                }
            }
            #newsletter-iframe {
                margin: 5px;
                width: 500px;
                height: 400px;
                border: 0;
                xmargin: 0;
            }
        </style>
        
<!-- This site is optimized with the Yoast SEO plugin v3.8 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Team Legacy Zw: Championing the Zim Hip Hop movement - Zimbo Jam" />
<meta property="og:description" content="Former U.S President Barrack Obama once remarked, “The thing about hip-hop today is it is smart, it is insightful. The &hellip;" />
<meta property="og:url" content="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" />
<meta property="og:site_name" content="Zimbo Jam" />
<meta property="article:publisher" content="https://www.facebook.com/zimbojam" />
<meta property="article:tag" content="Bryce Nation" />
<meta property="article:tag" content="DJ Tamuka" />
<meta property="article:tag" content="GZE" />
<meta property="article:tag" content="John Cole" />
<meta property="article:tag" content="Junior Brown" />
<meta property="article:tag" content="MC Chitah" />
<meta property="article:tag" content="Sista Flame" />
<meta property="article:tag" content="Taona Matsvai" />
<meta property="article:tag" content="Team Legacy Zw" />
<meta property="article:tag" content="Tehn Diamond" />
<meta property="article:tag" content="Tinopona Katsande" />
<meta property="article:tag" content="Zim Hip Hop" />
<meta property="article:section" content="Featured" />
<meta property="article:published_time" content="2017-05-09T05:28:53+02:00" />
<meta property="og:image" content="http://www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg" />
<meta property="og:image:width" content="840" />
<meta property="og:image:height" content="486" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Former U.S President Barrack Obama once remarked, “The thing about hip-hop today is it is smart, it is insightful. The &hellip; " />
<meta name="twitter:title" content="Team Legacy Zw: Championing the Zim Hip Hop movement - Zimbo Jam" />
<meta name="twitter:site" content="@zimbojam" />
<meta name="twitter:image" content="https://i1.wp.com/www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg?fit=840%2C486" />
<meta name="twitter:creator" content="@zimbojam" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Zimbo Jam &raquo; Feed" href="http://www.zimbojam.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Zimbo Jam &raquo; Comments Feed" href="http://www.zimbojam.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Zimbo Jam &raquo; Team Legacy Zw: Championing the Zim Hip Hop movement Comments Feed" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.zimbojam.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.5"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ai1ec_style-css'  href='//www.zimbojam.com/wp-content/plugins/all-in-one-event-calendar/cache/9037ad5e_ai1ec_parsed_css.css?ver=2.5.13' type='text/css' media='all' />
<link rel='stylesheet' id='dzs.vplayer-css'  href='http://www.zimbojam.com/wp-content/plugins/dzs-videogallery/videogallery/vplayer.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='tubepress-theme-0-css'  href='http://www.zimbojam.com/wp-content/plugins/tubepress/web/themes/default/css/tubepress.css?ver=5.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='http://www.zimbojam.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.zimbojam.com/wp-includes/css/dashicons.min.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='http://www.zimbojam.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.zimbojam.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mashsb-styles-css'  href='http://www.zimbojam.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.3.4' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 150px;}}
</style>
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://www.zimbojam.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.2.5.2' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='this-day-in-history-css'  href='http://www.zimbojam.com/wp-content/plugins/this-day-in-history/tdih.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='wmlp_lightbox_css-css'  href='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/js/colorbox/colorbox.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='wmlp_client_style-css'  href='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/css/wmlc_client.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='wmlp_icon_style-css'  href='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/icons/style.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://www.zimbojam.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://www.zimbojam.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='core-extend-css'  href='http://www.zimbojam.com/wp-content/plugins/core-extend/assets/css/core-extend.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='mnky_jquery.mmenu-css'  href='http://www.zimbojam.com/wp-content/themes/bitz/css/jquery.mmenu.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='mnky_main-css'  href='http://www.zimbojam.com/wp-content/themes/bitz/style.css?ver=4.6.5' type='text/css' media='all' />
<style id='mnky_main-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mnky_post-icons-css'  href='http://www.zimbojam.com/wp-content/themes/bitz/css/post-icons.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='mnky_google-font-lato-css'  href='https://fonts.googleapis.com/css?family=Lato:400,300,700,900' type='text/css' media='all' />
<link rel='stylesheet' id='mnky_google-font-roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto:400,300,500,700,900' type='text/css' media='all' />
<link rel='stylesheet' id='recently-css'  href='http://www.zimbojam.com/wp-content/plugins/recently/style/recently.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-css'  href='http://www.zimbojam.com/wp-content/plugins/easy-social-share-buttons3/assets/css/default-retina/easy-social-share-buttons.css?ver=3.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='essb-cct-style-css'  href='http://www.zimbojam.com/wp-content/plugins/easy-social-share-buttons3/lib/modules/click-to-tweet/assets/css/styles.css?ver=3.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-subscription-css'  href='http://www.zimbojam.com/wp-content/plugins/newsletter/subscription/style.css?ver=4.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='ms-main-css'  href='http://www.zimbojam.com/wp-content/plugins/masterslider/public/assets/css/masterslider.main.css?ver=2.29.0' type='text/css' media='all' />
<link rel='stylesheet' id='ms-custom-css'  href='http://www.zimbojam.com/wp-content/uploads/masterslider/custom.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://www.zimbojam.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.zimbojam.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/tubepress/web/js/tubepress.js?ver=5.1.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/tubepress/web/js/wordpress-ajax.js?ver=5.1.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.2.5.2'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.2.5.2'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/js/wmljs.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/js/jquery.infinitescroll.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/js/colorbox/jquery.colorbox-min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/wp-masonry-layout-pro/js/jquery.lazyload.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/wppas/templates/js/advertising.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-admin/admin-ajax.php?action=wppas_asyncjs&#038;ver=4.6.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FlowFlowOpts = {"streams":{"id1":{"id":"1","name":"social_watch","feeds":"[{\"content\":\"263Chat\",\"retweets\":\"nope\",\"replies\":\"nope\",\"id\":\"uy88470\",\"type\":\"twitter\",\"filter-by-words\":\"natgalleryzim\"},{\"content\":\"natgalleryzim\",\"id\":\"hx21109\",\"type\":\"instagram\",\"filter-by-words\":\"ameeramimi\"},{\"content\":\"ameeramimi\",\"id\":\"hv04472\",\"type\":\"instagram\"}]","posts":"40","cache":"yep","cache-lifetime":"10","private":"nope","hide-on-desktop":"nope","hide-on-mobile":"nope","heading":"","headingcolor":"rgb(228, 28, 7)","subheading":"","subheadingcolor":"rgb(114, 112, 114)","hhalign":"center","bgcolor":"rgb(229, 229, 229)","mobileslider":"nope","viewportin":"yep","layout":"grid","theme":"classic","gc-style":"style-4","width":"260","margin":"20","cardcolor":"rgb(255, 255, 255)","namecolor":"rgb(228, 28, 7)","textcolor":"rgb(85, 85, 85)","linkscolor":"rgb(94, 159, 202)","restcolor":"rgb(132, 118, 129)","shadow":"rgba(0, 0, 0, 0.22)","bcolor":"rgba(240, 237, 231, 0.4)","talign":"left","css":""}},"open_in_new":"yep","filter_all":"All","filter_search":"Search","expand_text":"Expand","collapse_text":"Collapse","posted_on":"Posted on","show_more":"Show more","dates":{"Yesterday":"Yesterday","s":"s","m":"m","h":"h","ago":"ago","months":["Jan","Feb","March","April","May","June","July","Aug","Sept","Oct","Nov","Dec"]},"lightbox_navigate":"Navigate with arrow keys","server_time":"1494380813","isAdmin":"","forceHTTPS":"nope","isLog":"","plugin_ver":"1.3.13"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/flow-flow-social-streams/js/require-utils.js?ver=1.0.5'></script>
<link rel='https://api.w.org/' href='http://www.zimbojam.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.zimbojam.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.zimbojam.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.6.5" />
<link rel='shortlink' href='http://wp.me/p7Xkla-6yr' />
<link rel="alternate" type="application/json+oembed" href="http://www.zimbojam.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.zimbojam.com%2Fteam-legacy-zw-championing-zim-hip-hop-movement%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.zimbojam.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.zimbojam.com%2Fteam-legacy-zw-championing-zim-hip-hop-movement%2F&#038;format=xml" />
<script>window.dzsvg_settings= {dzsvg_site_url: "http://www.zimbojam.com/",version: "9.66",ajax_url: "http://www.zimbojam.com/wp-admin/admin-ajax.php"}; window.dzsvg_site_url="http://www.zimbojam.com";window.dzsvg_plugin_url="http://www.zimbojam.com/wp-content/plugins/dzs-videogallery/";</script><script>var ms_grabbing_curosr='http://www.zimbojam.com/wp-content/plugins/masterslider/public/assets/css/common/grabbing.cur',ms_grab_curosr='http://www.zimbojam.com/wp-content/plugins/masterslider/public/assets/css/common/grab.cur';</script>
<meta name="generator" content="MasterSlider 2.29.0 - Responsive Touch Image Slider" />


<script type="text/javascript">var TubePressJsConfig = {"urls":{"base":"\/wp-content\/plugins\/tubepress","usr":"\/wp-content\/tubepress-content","ajax":"\/wp-admin\/admin-ajax.php"}};</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Content is protected from copying.";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<meta name="google-site-verification" content="vfbGwlrl1ZVOYf4eQXvSa9hfDqs03mGBUKc3g1r-KQ8" />
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.essb_links_list li.essb_totalcount_item .essb_t_l_big .essb_t_nb:after, .essb_links_list li.essb_totalcount_item .essb_t_r_big .essb_t_nb:after { color: #777777;content: "shares";display: block;font-size: 11px;font-weight: normal;text-align: center;text-transform: uppercase;margin-top: -5px; } .essb_links_list li.essb_totalcount_item .essb_t_l_big, .essb_links_list li.essb_totalcount_item .essb_t_r_big { text-align: center; }.essb_displayed_sidebar .essb_links_list li.essb_totalcount_item .essb_t_l_big .essb_t_nb:after, .essb_displayed_sidebar .essb_links_list li.essb_totalcount_item .essb_t_r_big .essb_t_nb:after { margin-top: 0px; } .essb_displayed_sidebar_right .essb_links_list li.essb_totalcount_item .essb_t_l_big .essb_t_nb:after, .essb_displayed_sidebar_right .essb_links_list li.essb_totalcount_item .essb_t_r_big .essb_t_nb:after { margin-top: 0px; } .essb_totalcount_item_before, .essb_totalcount_item_after { display: block !important; }.essb_totalcount_item_before .essb_totalcount, .essb_totalcount_item_after .essb_totalcount { border: 0px !important; }.essb_counter_insidebeforename { margin-right: 5px; font-weight: bold; }.essb_width_columns_1 li { width: 100%; }.essb_width_columns_1 li a { width: 92%; }.essb_width_columns_2 li { width: 49%; }.essb_width_columns_2 li a { width: 86%; }.essb_width_columns_3 li { width: 32%; }.essb_width_columns_3 li a { width: 80%; }.essb_width_columns_4 li { width: 24%; }.essb_width_columns_4 li a { width: 70%; }.essb_width_columns_5 li { width: 19.5%; }.essb_width_columns_5 li a { width: 60%; }.essb_width_columns_6 li { width: 16%; }.essb_width_columns_6 li a { width: 55%; }.essb_links li.essb_totalcount_item_before, .essb_width_columns_1 li.essb_totalcount_item_after { width: 100%; text-align: left; }.essb_network_align_center a { text-align: center; }.essb_network_align_right .essb_network_name { float: right;}</style>
<script type="text/javascript">var essb_settings = {"ajax_url":"http:\/\/www.zimbojam.com\/wp-admin\/admin-ajax.php","essb3_nonce":"b27effd9f4","essb3_plugin_url":"http:\/\/www.zimbojam.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_facebook_total":true,"essb3_admin_ajax":false,"essb3_internal_counter":false,"essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","essb3_counter_button_min":0,"essb3_counter_total_min":0,"blog_url":"http:\/\/www.zimbojam.com\/","ajax_type":"wp","essb3_postfloat_stay":false,"essb3_no_counter_mailprint":false,"essb3_single_ajax":false,"twitter_counter":"self","post_id":25199};</script><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.zimbojam.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- Dynamic Widgets by QURL - http://www.qurl.nl //-->
<meta name="generator" content="Powered by Slider Revolution 5.2.5.2 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<link rel="icon" href="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2016/06/cropped-Z.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2016/06/cropped-Z.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2016/06/cropped-Z.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2016/06/cropped-Z.png?fit=270%2C270" />
<style>
            a.newsletter-facebook-button, a.newsletter-facebook-button:visited, a.newsletter-facebook-button:hover {
            display: inline-block;
            background-color: #3B5998;
            border-radius: 3px!important;
            color: #fff!important;
            text-decoration: none;
            font-size: 14px;
            padding: 7px!important;
            line-height: normal;
            margin: 0;
            border: 0;
            text-align: center;
            }
            </style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="81ecb35ba18dfc1abb6a83a1a9536628"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script pagespeed_no_defer="" data-pso-version="20170403_083938">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</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-3185541-24', 'auto');
  ga('send', 'pageview');

</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-2796460427201817",
    enable_page_level_ads: true
  });
</script>
</head>
	
	
<body class="single single-post postid-25199 single-format-standard sticky-sidebar _masterslider _msp_version_2.29.0 unselectable wpb-js-composer js-comp-ver-5.0.1 vc_responsive" id="site-body" itemscope itemtype="http://schema.org/WebPage">
	<div id="wrapper">
		

	
		
			


	
<header id="mobile-site-header" class="mobile-header">
<div id="mobile-site-logo">
<a href="http://www.zimbojam.com/">
				<img src="http://www.zimbojam.com/wp-content/uploads/2016/06/Zimbo-Jam-Logo-178x65.png" width="178" height="65" alt="Zimbo Jam" class="default-logo" />
				<img src="http://www.zimbojam.com/wp-content/uploads/2016/06/Zimbo-Jam-Logo-357x130.png" width="178" height="65" alt="Zimbo Jam" class="retina-logo" />
			</a></div>		
<a href="#mobile-site-navigation" class="toggle-mobile-menu"><i class="fa fa-bars"></i></a>	
</header>	
	

		
	<header id="site-header" class="header-style-1" itemscope itemtype="http://schema.org/WPHeader">
		<div id="header-wrapper">
			<div id="header-container" class="clearfix">
				<div id="site-logo">
					<a href="http://www.zimbojam.com/">
				<img src="http://www.zimbojam.com/wp-content/uploads/2016/06/Zimbo-Jam-Logo-220x80.png" width="220" height="80" alt="Zimbo Jam" class="default-logo" />
				<img src="http://www.zimbojam.com/wp-content/uploads/2016/06/Zimbo-Jam-Logo-440x160.png" width="220" height="80" alt="Zimbo Jam" class="retina-logo" />
			</a>				</div>			

				<div id="header-sidebar" class="clearfix">

					<ul class="header-widget-area">
					<li id="wppas_custom_widgets-4" class="widget-container wppaszone"><div  class="paszone_container paszone-container-22258   " id="paszonecont_22258" style="overflow:hidden; max-width:728px;   " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-22258 " id="22258" style="overflow:hidden; max-width:728px; max-height:90px;  "><div class="wppasrotate   proadszoneholder-22258" style="" ><div class="pasli pasli-22260 "  data-duration="15000" bid="22260" aid="22258"><a class="wpproaddlink" href="http://www.zimbojam.com?pasID=MjIyNjA=&amp;pasZONE=MjIyNTg=" target="_blank" ><img src="http://www.zimbojam.com/wp-content/uploads/2016/06/11422-telecel-go-MegaBOOST-ONLINE_728x90.jpg?pas=6202469321705100146" alt="Telecel &#8211; leaderboard banner" border="0"  /></a></div></div></div></div></li>			</ul>
			

</div>
			</div><!-- #header-container -->
		</div><!-- #header-wrapper -->	
	</header><!-- #site-header -->

	<div id="navigation-wrapper" class="header-style-1">
		<div id="navigation-container">
			<div id="navigation-inner" class="clearfix">
				
				<nav id="site-navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
					<div class="menu-container"><ul id="menu-zimbo-jam-main-menu" class="menu"><li id="menu-item-19396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19396"><a href="http://www.zimbojam.com/">Home</a></li>
<li id="menu-item-19445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19445"><a href="http://www.zimbojam.com/category/society/">Society</a>
<ul class="sub-menu">
	<li id="menu-item-22441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22441"><a href="http://www.zimbojam.com/category/society/young-shakers/">Young Shakers</a></li>
	<li id="menu-item-20819" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20819"><a href="http://www.zimbojam.com/category/society/opinion-advice/">Opinion &#038; Advice</a></li>
	<li id="menu-item-19446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19446"><a href="http://www.zimbojam.com/category/society/travel-stories/">Travel</a></li>
	<li id="menu-item-19447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19447"><a href="http://www.zimbojam.com/category/society/trends/">Trends</a></li>
	<li id="menu-item-19397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19397"><a href="http://www.zimbojam.com/social-watch/">Social Media Watch</a></li>
</ul>
</li>
<li id="menu-item-19434" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-19434"><a href="http://www.zimbojam.com/category/arts/">Arts</a>
<ul class="sub-menu">
	<li id="menu-item-19439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19439"><a href="http://www.zimbojam.com/category/arts/theatre/">Theatre &#038; Comedy</a></li>
	<li id="menu-item-19438" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-19438"><a href="http://www.zimbojam.com/category/arts/music/">Music</a></li>
	<li id="menu-item-19436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19436"><a href="http://www.zimbojam.com/category/arts/dance/">Dance</a></li>
	<li id="menu-item-19435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19435"><a href="http://www.zimbojam.com/category/arts/books/">Books</a></li>
	<li id="menu-item-19437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19437"><a href="http://www.zimbojam.com/category/arts/film-tv/">Film &#038; TV</a></li>
	<li id="menu-item-19440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19440"><a href="http://www.zimbojam.com/category/arts/visual-arts/">Visual Arts</a></li>
</ul>
</li>
<li id="menu-item-19441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19441"><a href="http://www.zimbojam.com/category/culture/">Culture</a>
<ul class="sub-menu">
	<li id="menu-item-19442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19442"><a href="http://www.zimbojam.com/category/culture/fashion/">Fashion</a></li>
	<li id="menu-item-19443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19443"><a href="http://www.zimbojam.com/category/culture/fashion-pics/">Fashion Pics</a></li>
	<li id="menu-item-19444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19444"><a href="http://www.zimbojam.com/category/culture/pageants-modelling/">Pageants &#038; Modelling</a></li>
</ul>
</li>
<li id="menu-item-19448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19448"><a href="http://www.zimbojam.com/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-19449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19449"><a href="http://www.zimbojam.com/category/multimedia/pictures/">In Pictures</a></li>
	<li id="menu-item-19450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19450"><a href="http://www.zimbojam.com/category/multimedia/video/">In Video</a></li>
	<li id="menu-item-22702" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22702"><a href="http://www.zimbojam.com/jam-tv/">Jam TV</a></li>
</ul>
</li>
<li id="menu-item-19467" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19467"><a href="#">Community</a>
<ul class="sub-menu">
	<li id="menu-item-19473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19473"><a href="http://www.zimbojam.com/notebook/">Notebook</a></li>
	<li id="menu-item-19453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19453"><a href="http://www.zimbojam.com/noticeboard/">Noticeboard</a></li>
	<li id="menu-item-19456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19456"><a href="http://www.zimbojam.com/newsletter/">Newsletter</a></li>
</ul>
</li>
<li id="menu-item-19991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19991"><a href="http://www.zimbojam.com/gigs/">Gig Guide</a></li>
</ul></div>				</nav><!-- #site-navigation -->
								
				<div id="site-utility">
																
											<button id="trigger-header-search" class="search_button" type="button">
							<i class="fa fa-search"></i>
						</button>
											
					
				</div>
									
									<div class="header-search">
							<div class="searchform-wrapper">
		<form method="get" class="searchform" action="http://www.zimbojam.com/">
			<input onfocus="this.value=''" onblur="this.value='Type and hit enter to search ...'" type="text" value="Type and hit enter to search ..." name="s" class="search-input" />
		</form>
	</div>					</div>
										
			</div><!-- #navigation-inner -->
		</div><!-- #navigation-container -->
	</div><!-- #navigation-wrapper -->
		
	
		

	
		
		
		
		
		<div id="main" class="clearfix">
			
		<div id="container" class="clearfix">

				<div id="content" class="float-left">
				
					
						
	<article itemtype="http://schema.org/Article" itemscope="" id="post-25199" class="single-layout clearfix post-25199 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music tag-bryce-nation tag-dj-tamuka tag-gze tag-john-cole tag-junior-brown tag-mc-chitah tag-sista-flame tag-taona-matsvai tag-team-legacy-zw tag-tehn-diamond tag-tinopona-katsande tag-zim-hip-hop" >
	
	<link itemprop="mainEntityOfPage" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" />
		
				<header class="entry-header clearfix">
				
						<h5><a href="http://www.zimbojam.com/category/featured/" rel="category tag">Featured</a>, <a href="http://www.zimbojam.com/category/arts/music/" rel="category tag">Music</a></h5>
						<h1 itemprop="headline" class="entry-title">Team Legacy Zw: Championing the Zim Hip Hop movement</h1>
			<div class="entry-meta"><span class="meta-author-image"><img src="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2016/06/Courage-Chakubva-ct.jpg?fit=50%2C50" width="50" height="50" alt="Courage Chakubva" class="avatar avatar-50 wp-user-avatar wp-user-avatar-50 alignnone photo" /></span><a class="meta-author url" href="http://www.zimbojam.com/author/chuck_tafadzwa/" title="View all posts by Courage Chakubva" rel="author"><span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name">Courage Chakubva</span></span></a><span class="meta-date"><time class="published" datetime="2017-05-09T05:28:53+00:00" itemprop="datePublished">22 hours ago</time><time class="meta-date-modified updated" datetime="2017-05-09T05:28:53+00:00" itemprop="dateModified">May 9, 2017</time></span><span class="meta-comments"><i class="post-icon icon-comments"></i> <a href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/#respond">0</a></span><meta itemprop="interactionCount" content="UserComments:0"/><span class="meta-views"><span class="views-mid" title="Views"><i class="post-icon icon-views"></i> 192<meta itemprop="interactionCount" content="UserPageVisits:192"/></span></span></div>			<aside id="post-header-sidebar" class="clearfix">

			

</aside>				
		</header><!-- .entry-header -->
					
		<div class="post-preview"><img width="840" height="486" src="https://i1.wp.com/www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg?fit=840%2C486" class="attachment-large size-large wp-post-image" alt="MC CHITA in action at HIFA 2017 PIC: T. CHIHAMBAKWE | ZIMBOJAM.COM" srcset="https://i1.wp.com/www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg?w=840 840w, https://i1.wp.com/www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg?resize=300%2C174 300w, https://i1.wp.com/www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg?resize=768%2C444 768w" sizes="(max-width: 840px) 100vw, 840px" /></div>		<div class="mnky-featured-image-caption clearfix">MC CHITA in action at HIFA 2017 PIC: T. CHIHAMBAKWE | ZIMBOJAM.COM</div>
					
	
				
		
				<aside id="post-content-top-sidebar" class="clearfix">
			<div class="post-widget-area">
					<div id="wppas_custom_widgets-5" class="widget wppaszone"><div  class="paszone_container paszone-container-22606   " id="paszonecont_22606" style="overflow:hidden;    " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-22606 " id="22606" style="overflow:hidden;  width:100%; height:auto; display:inline-block;   "><div class="wppasrotate   proadszoneholder-22606" style="width:100%; height:100%;" ></div></div></div></div>			</div>
		</aside>
			
		
			
		
		<div itemprop="articleBody" class="entry-content">
			<aside class="mashsb-container mashsb-main "><div class="mashsb-box"><div class="mashsb-count" style="float:left;"><div class="counts mashsbcount">9</div><span class="mashsb-sharetext">SHARES</span></div><div class="mashsb-buttons"><a  class="mashicon-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.zimbojam.com%2Fteam-legacy-zw-championing-zim-hip-hop-movement%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a  class="mashicon-twitter" href="https://twitter.com/intent/tweet?text=Team%20Legacy%20Zw%3A%20Championing%20the%20Zim%20Hip%20Hop%20movement&url=http://wp.me/p7Xkla-6yr&via=zimbojam" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><a  class="mashicon-subscribe" href="#" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Receive&nbsp;Updates</span></a><div class="onoffswitch2" style="display:none;"></div></div>
            </div>
                <div style="clear:both;"></div></aside>
            <!-- Share buttons by mashshare.net - Version: 3.3.4--><p>Former U.S President Barrack Obama once remarked, “The thing about hip-hop today is it is smart, it is insightful. The way they can communicate a complex message in a very short space is remarkable.”<span id="more-25199"></span></p>
<p>What is more remarkable about such a brilliant observation is the individuals/ organisations that promote both forthcoming and established rap artistes.</p>
<p>Hip hop is a culture characterised by rapping, beat-boxing, graffiti, dance and DJing. Whether the performances are on the mainstream media or on the streets, Team Legacy Zw is there to propel the culture to greater heights through the provision of a platform for the artists to showcase their aptitude.</p>
<p>“My main aim is to push upcoming and unknown artistes both from the high and low density suburbs so that they earn recognition in the mainstream media which will improve their lives and foster positive behaviour change,” said Taona Matsvai the CEO and founder of Team Legacy Zw.</p>
<p>Team Legacy Zimbabwe has been carrying out street hip hop tours with the anticipation of providing a platform for unknown artistes to showcase their talent and currently these have been hosted in Mufakose, Glennorah, Chitungwiza and Southerton.</p>
<p>“We mainly host our shows in places where most locals are familiar with, where most locals shop, or places where they go to interact or socialise. In as much as these shows just began, we have received a positive response in terms of the outcome in attendance and the number of the songs played during the shows,” added Taona Matsvai.</p>
<p>Team Legacy Zw has worked with high profile individuals in the arts and entertainment industry including Junior Brown, Tinopona Katsande, Sista Flame, MC Chitah, GZE, John Cole, DJ Tamuka, Bryce Nation and TehN Diamond.</p>
<p>The organisation predominantly wants to promote hip hop artists across Zimbabwe and propel local rap acts on to the international stage which will inevitably make Zimbabwe to participate in the global village.</p>
<div class="essb_links essb_counter_modern_right essb_displayed_bottom essb_share essb_template_default-retina essb_100427172 print-no" id="essb_displayed_bottom_100427172" data-essb-postid="25199" data-essb-position="bottom" data-essb-button-style="button" data-essb-template="default-retina" data-essb-counter-pos="right" data-essb-url="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" data-essb-twitter-url="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" data-essb-instance="100427172"><ul class="essb_links_list"><li class="essb_item essb_link_facebook nolightbox"> <a href="http://www.facebook.com/sharer/sharer.php?u=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/&t=Team+Legacy+Zw%3A+Championing+the+Zim+Hip+Hop+movement" title="" onclick="essb_window(&#39;http://www.facebook.com/sharer/sharer.php?u=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/&t=Team+Legacy+Zw%3A+Championing+the+Zim+Hip+Hop+movement&#39;,&#39;facebook&#39;,&#39;100427172&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb_window(&#39;https://twitter.com/intent/tweet?text=Team+Legacy+Zw%3A+Championing+the+Zim+Hip+Hop+movement&amp;url=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/&amp;counturl=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/&#39;,&#39;twitter&#39;,&#39;100427172&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" title="" onclick="essb_window(&#39;https://plus.google.com/share?url=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/&#39;,&#39;google&#39;,&#39;100427172&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name">Google+</span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb_pinterest_picker(&#39;100427172&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="http://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Team+Legacy+Zw%3A+Championing+the+Zim+Hip+Hop+movement&amp;url=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/" title="" onclick="essb_window(&#39;http://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Team+Legacy+Zw%3A+Championing+the+Zim+Hip+Hop+movement&amp;url=http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/&#39;,&#39;linkedin&#39;,&#39;100427172&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon"></span><span class="essb_network_name">LinkedIn</span></a></li></ul></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-25199" class="share-twitter sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-25199" class="share-facebook sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-25199" class="share-linkedin sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-25199" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.zimbojam.com/team-legacy-zw-championing-zim-hip-hop-movement/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>		</div><!-- .entry-content -->
				
				
					
				<div class="entry-meta-footer"><div class="tag-links"><span><a href="http://www.zimbojam.com/tag/bryce-nation/" rel="tag">Bryce Nation</a></span><span><a href="http://www.zimbojam.com/tag/dj-tamuka/" rel="tag">DJ Tamuka</a></span><span><a href="http://www.zimbojam.com/tag/gze/" rel="tag">GZE</a></span><span><a href="http://www.zimbojam.com/tag/john-cole/" rel="tag">John Cole</a></span><span><a href="http://www.zimbojam.com/tag/junior-brown/" rel="tag">Junior Brown</a></span><span><a href="http://www.zimbojam.com/tag/mc-chitah/" rel="tag">MC Chitah</a></span><span><a href="http://www.zimbojam.com/tag/sista-flame/" rel="tag">Sista Flame</a></span><span><a href="http://www.zimbojam.com/tag/taona-matsvai/" rel="tag">Taona Matsvai</a></span><span><a href="http://www.zimbojam.com/tag/team-legacy-zw/" rel="tag">Team Legacy Zw</a></span><span><a href="http://www.zimbojam.com/tag/tehn-diamond/" rel="tag">Tehn Diamond</a></span><span><a href="http://www.zimbojam.com/tag/tinopona-katsande/" rel="tag">Tinopona Katsande</a></span><span><a href="http://www.zimbojam.com/tag/zim-hip-hop/" rel="tag">Zim Hip Hop</a></span></div></div>		<div class="mnky-post-links clearfix"><span class="previous-post-link"><span class="previous-post-title">Previous Article</span><a href="http://www.zimbojam.com/street-corner-symphony-rocks-hifa/" rel="prev">Street Corner Symphony rocks HIFA</a></span><span class="next-post-link"><span class="previous-post-title">Next Article</span><a href="http://www.zimbojam.com/off-broadway-play-comes-theatre-park/" rel="next">Off Broadway play comes to Theatre in the Park</a></span></div>	
				
				
				
				<div class="hidden-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/www.zimbojam.com/wp-content/uploads/2017/05/MC-CHITA-in-action-at-HIFA-2017.jpg?fit=840%2C486"><meta itemprop="width" content="840"><meta itemprop="height" content="486"></div>
				
		<div class="hidden-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
			<div class="hidden-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
			<meta itemprop="url" content="http://www.zimbojam.com/wp-content/uploads/2016/06/Zimbo-Jam-Logo-220x80.png">
			<meta itemprop="width" content="220">
			<meta itemprop="height" content="80">
			</div>
			<meta itemprop="name" content="Zimbo Jam">
		</div>		
	</article><!-- #post-25199 -->
	
			<div class="author vcard clearfix">
		<img src="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2016/06/Courage-Chakubva-ct.jpg?fit=100%2C100" width="100" height="100" alt="Courage Chakubva" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 alignnone photo" />			<div class="fn">
				<a class="url" href="http://www.zimbojam.com/author/chuck_tafadzwa/" title="View all posts by Courage Chakubva" rel="author">Courage Chakubva</a>			</div><!-- .fn -->	
			<div class="author-info description note">
				A progressive thinker concerned with society's activities and observing of human rights			</div><!-- .author-info .description .note -->
		</div><!-- .author .vcard-->
					

	<aside id="after-post-sidebar" class="clearfix">

					<div class="after-post-widget-area">
					<div id="ai1ec_agenda_widget-6" class="widget widget_ai1ec_agenda_widget">

	<h3 class="content-widget-title">From the Gig Guide</h3>

<style>
<!--

-->
</style>
<div class="timely ai1ec-agenda-widget-view ai1ec-clearfix">

			<div>
													<div class="ai1ec-date
					">
					<a class="ai1ec-date-title ai1ec-load-view"
						href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;gigs&#x2F;action&#x7E;oneday&#x2F;exact_date&#x7E;20-5-2017&#x2F;">
						<div class="ai1ec-month">May</div>
						<div class="ai1ec-day">20</div>
						<div class="ai1ec-weekday">Sat</div>
											</a>
					<div class="ai1ec-date-events">
													 																					<div class="ai1ec-event
									ai1ec-event-id-24793
									ai1ec-event-instance-id-457
									">

									<a href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;hats-heels-high-tea&#x2F;&#x3F;instance_id&#x3D;457"
										class="ai1ec-popup-trigger ai1ec-load-event">
																					<span class="ai1ec-event-time">
												2:00 pm
											</span>
										
										<span class="ai1ec-event-title">
											Hats &amp; Heels High Tea
																							<span class="ai1ec-event-location"
													>@ The Cottage Cafe</span>
																					</span>
									</a>

									<div class="ai1ec-popover ai1ec-popup ">

		
	<span class="ai1ec-popup-title">
		<a href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;hats-heels-high-tea&#x2F;&#x3F;instance_id&#x3D;457"
		   class="ai1ec-load-event"
			>Hats &amp; Heels High Tea</a>
					<span class="ai1ec-event-location"
				>@ The Cottage Cafe</span>
					</span>

	
	<div class="ai1ec-event-time">
					May 20 @ 2:00 pm – 4:00 pm
			</div>

			<a class="ai1ec-load-event"
			href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;hats-heels-high-tea&#x2F;&#x3F;instance_id&#x3D;457">
			<div class="ai1ec-event-avatar timely  ai1ec-post_thumbnail ai1ec-portrait"><img src="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2017/03/17309442_418586468475654_7356655134276901615_n.jpg?fit=300%2C300" alt="Hats &amp; Heels High Tea @ The Cottage Cafe | Harare | Zimbabwe" width="300" height="300" /></div>
		</a>
	
			<div class="ai1ec-popup-excerpt">&nbsp;</div>
	
</div>

								</div>
							 						 					</div>
				</div>
							<div class="ai1ec-date
					">
					<a class="ai1ec-date-title ai1ec-load-view"
						href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;gigs&#x2F;action&#x7E;oneday&#x2F;exact_date&#x7E;26-5-2017&#x2F;">
						<div class="ai1ec-month">May</div>
						<div class="ai1ec-day">26</div>
						<div class="ai1ec-weekday">Fri</div>
											</a>
					<div class="ai1ec-date-events">
													 																					<div class="ai1ec-event
									ai1ec-event-id-24787
									ai1ec-event-instance-id-454
									">

									<a href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;green-africa-expo-2017&#x2F;&#x3F;instance_id&#x3D;454"
										class="ai1ec-popup-trigger ai1ec-load-event">
																					<span class="ai1ec-event-time">
												8:00 am
											</span>
										
										<span class="ai1ec-event-title">
											Green Africa Expo 2017
																							<span class="ai1ec-event-location"
													>@ Rainbow Towers Hotel &amp; Conference Centre</span>
																					</span>
									</a>

									<div class="ai1ec-popover ai1ec-popup ">

		
	<span class="ai1ec-popup-title">
		<a href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;green-africa-expo-2017&#x2F;&#x3F;instance_id&#x3D;454"
		   class="ai1ec-load-event"
			>Green Africa Expo 2017</a>
					<span class="ai1ec-event-location"
				>@ Rainbow Towers Hotel &amp; Conference Centre</span>
					</span>

	
	<div class="ai1ec-event-time">
					May 26 @ 8:00 am – May 27 @ 5:00 pm
			</div>

			<a class="ai1ec-load-event"
			href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;green-africa-expo-2017&#x2F;&#x3F;instance_id&#x3D;454">
			<div class="ai1ec-event-avatar timely  ai1ec-post_thumbnail ai1ec-landscape"><img src="https://i0.wp.com/www.zimbojam.com/wp-content/uploads/2017/03/16266325_1660527724254575_3788941030845761632_n.jpg?fit=300%2C210" alt="Green Africa Expo 2017 @ Rainbow Towers Hotel &amp; Conference Centre | Harare | Harare Province | Zimbabwe" width="300" height="210" /></div>
		</a>
	
			<div class="ai1ec-popup-excerpt">GCA promotes awareness, sensitize communities about habitual environmental cleanliness, through advocacy for cleaner, greener and healthier waste disposal. Promoting corporate &hellip; </div>
	
</div>

								</div>
							 						 					</div>
				</div>
							<div class="ai1ec-date
					">
					<a class="ai1ec-date-title ai1ec-load-view"
						href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;gigs&#x2F;action&#x7E;oneday&#x2F;exact_date&#x7E;28-7-2017&#x2F;">
						<div class="ai1ec-month">Jul</div>
						<div class="ai1ec-day">28</div>
						<div class="ai1ec-weekday">Fri</div>
											</a>
					<div class="ai1ec-date-events">
																					<div class="ai1ec-event
									ai1ec-event-id-24073
									ai1ec-event-instance-id-424
									ai1ec-allday">

									<a href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;lake-july-festival-2017&#x2F;&#x3F;instance_id&#x3D;424"
										class="ai1ec-popup-trigger ai1ec-load-event">
																					<span class="ai1ec-allday-badge">
												all-day
											</span>
										
										<span class="ai1ec-event-title">
											Lake July Festival 2017
																							<span class="ai1ec-event-location"
													>@ Lake Chivero</span>
																					</span>
									</a>

									<div class="ai1ec-popover ai1ec-popup ">

		
	<span class="ai1ec-popup-title">
		<a href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;lake-july-festival-2017&#x2F;&#x3F;instance_id&#x3D;424"
		   class="ai1ec-load-event"
			>Lake July Festival 2017</a>
					<span class="ai1ec-event-location"
				>@ Lake Chivero</span>
					</span>

	
	<div class="ai1ec-event-time">
					Jul 28 – Jul 30 <span class="ai1ec-allday-badge">all-day</span>
			</div>

			<a class="ai1ec-load-event"
			href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;event&#x2F;lake-july-festival-2017&#x2F;&#x3F;instance_id&#x3D;424">
			<div class="ai1ec-event-avatar timely  ai1ec-post_thumbnail ai1ec-portrait"><img src="https://i2.wp.com/www.zimbojam.com/wp-content/uploads/2017/02/IMG-20170205-WA0001.jpg?fit=208%2C300" alt="Lake July Festival 2017 @ Lake Chivero | Zimbabwe" width="208" height="300" /></div>
		</a>
	
			<div class="ai1ec-popup-excerpt">Ecrag Group and StarFM bring you the biggest DJ party  ever!!!! The Lake July DJ Festival! Hunyani Hills Hotel on the shores &hellip; </div>
	
</div>

								</div>
							 													 						 					</div>
				</div>
			 		</div>
	 
			<div class="ai1ec-subscribe-buttons-widget">
							<a class="ai1ec-btn ai1ec-btn-default ai1ec-btn-xs ai1ec-pull-right
					ai1ec-calendar-link"
					href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;gigs&#x2F;">
					View Calendar
					<i class="ai1ec-fa ai1ec-fa-arrow-right"></i>
				</a>
			
							<div class="ai1ec-subscribe-dropdown ai1ec-dropdown ai1ec-btn
	ai1ec-btn-default ai1ec-btn-xs">
	<span role="button" class="ai1ec-dropdown-toggle ai1ec-subscribe"
			data-toggle="ai1ec-dropdown">
		<i class="ai1ec-fa ai1ec-icon-rss ai1ec-fa-lg ai1ec-fa-fw"></i>
		<span class="ai1ec-hidden-xs">
							Add
						<span class="ai1ec-caret"></span>
		</span>
	</span>
			<ul class="ai1ec-dropdown-menu ai1ec-pull-left" role="menu">
		<li>
			<a class="ai1ec-tooltip-trigger ai1ec-tooltip-auto" target="_blank"
				data-placement="right" title="Copy this URL for your own Timely calendar or click to add to your rich-text calendar"
				href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;&#x3F;plugin&#x3D;all-in-one-event-calendar&amp;controller&#x3D;ai1ec_exporter_controller&amp;action&#x3D;export_events">
				<i class="ai1ec-fa ai1ec-fa-lg ai1ec-fa-fw ai1ec-icon-timely"></i>
				Add to Timely Calendar
			</a>
		</li>
		<li>
			<a class="ai1ec-tooltip-trigger ai1ec-tooltip-auto" target="_blank"
			  data-placement="right" title="Subscribe to this calendar in your Google Calendar"
			  href="http://www.google.com/calendar/render?cid=http&#x25;3A&#x25;2F&#x25;2Fwww.zimbojam.com&#x25;2F&#x25;3Fplugin&#x25;3Dall-in-one-event-calendar&#x25;26controller&#x25;3Dai1ec_exporter_controller&#x25;26action&#x25;3Dexport_events&#x25;26no_html&#x25;3Dtrue">
				<i class="ai1ec-fa ai1ec-icon-google ai1ec-fa-lg ai1ec-fa-fw"></i>
				Add to Google
			</a>
		</li>
		<li>
			<a class="ai1ec-tooltip-trigger ai1ec-tooltip-auto" target="_blank"
			  data-placement="right" title="Subscribe to this calendar in MS Outlook"
			  href="webcal&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;&#x3F;plugin&#x3D;all-in-one-event-calendar&amp;controller&#x3D;ai1ec_exporter_controller&amp;action&#x3D;export_events&amp;no_html&#x3D;true">
				<i class="ai1ec-fa ai1ec-icon-windows ai1ec-fa-lg ai1ec-fa-fw"></i>
				Add to Outlook
			</a>
		</li>
		<li>
			<a class="ai1ec-tooltip-trigger ai1ec-tooltip-auto" target="_blank"
			  data-placement="right" title="Subscribe to this calendar in Apple Calendar/iCal"
			  href="webcal&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;&#x3F;plugin&#x3D;all-in-one-event-calendar&amp;controller&#x3D;ai1ec_exporter_controller&amp;action&#x3D;export_events&amp;no_html&#x3D;true">
				<i class="ai1ec-fa ai1ec-icon-apple ai1ec-fa-lg ai1ec-fa-fw"></i>
				Add to Apple Calendar
			</a>
		</li>
		<li>
						<a class="ai1ec-tooltip-trigger ai1ec-tooltip-auto"
			  data-placement="right" title="Subscribe to this calendar in another plain-text calendar"
			  href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;&#x3F;plugin&#x3D;all-in-one-event-calendar&amp;controller&#x3D;ai1ec_exporter_controller&amp;action&#x3D;export_events&amp;no_html&#x3D;true">
				<i class="ai1ec-fa ai1ec-icon-calendar ai1ec-fa-fw"></i>
				Add to other calendar
			</a>
		</li>
		<li>
			<a class="ai1ec-tooltip-trigger ai1ec-tooltip-auto"
			  data-placement="right" title=""
			  href="http&#x3A;&#x2F;&#x2F;www.zimbojam.com&#x2F;&#x3F;plugin&#x3D;all-in-one-event-calendar&amp;controller&#x3D;ai1ec_exporter_controller&amp;action&#x3D;export_events&xml=true">
				<i class="ai1ec-fa ai1ec-fa-file-text ai1ec-fa-lg ai1ec-fa-fw"></i>
				Export to XML
			</a>
		</li>
	</ul>
</div>

					</div>
	 
</div>



</div>			</div>
			

</aside>						
						
<div id="comments" class="comments-area">

	

					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/team-legacy-zw-championing-zim-hip-hop-movement/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.zimbojam.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="cptch_block"><span class="cptch_title">Confirm that you are humann by solving the following problem...<span class="required"> *</span></span><span
				class="cptch_wrap cptch_ajax_wrap"
				data-cptch-form="wp_comments"
				data-cptch-input="cptch_number"
				data-cptch-class="cptch_wp_comments">
					<noscript>In order to pass the CAPTCHA please enable JavaScript</noscript>
				</span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='25199' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>				</form>
					</div><!-- #respond -->
		
</div><!-- #comments -->						
											
				</div><!-- #content -->
				
				<div itemscope itemtype="http://schema.org/WPSideBar" id="sidebar" class="float-right">
							<aside class="page-sidebar" itemscope itemtype="http://schema.org/WPSideBar">
			<div class="widget-area">
				<div id="search-2" class="widget widget_search">	<div class="searchform-wrapper">
		<form method="get" class="searchform" action="http://www.zimbojam.com/">
			<input onfocus="this.value=''" onblur="this.value='Type and hit enter to search ...'" type="text" value="Type and hit enter to search ..." name="s" class="search-input" />
		</form>
	</div></div><div id="wppas_custom_widgets-2" class="widget wppaszone"><div  class="paszone_container paszone-container-22245   " id="paszonecont_22245" style="overflow:hidden; max-width:400px;   " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-22245 " id="22245" style="overflow:hidden; max-width:400px; max-height:600px;  "><div class="wppasrotate   proadszoneholder-22245" style="width:100%; height:100%;" ></div></div></div></div><div id="vertical-scroll-recent-comments" class="widget vsrc_widget"><h3 class="widget-title">New Comments</h3>    <style type="text/css">
	.vsrc-regimag img { 
	float: left ;
	border: 1px solid #CCCCCC ;
	vertical-align:bottom; 
	padding: 3px ;
	margin-right: 2px;
	};
    </style>
    	
		<div style="padding-top:8px;padding-bottom:8px;">
			<div style="text-align:left;vertical-align:middle;text-decoration: none;overflow: hidden; position: relative; margin-left: 1px; height: 59px;" id="vsrc_Holder">
				<div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>Arthur: </span><span>Is there an entrance fee and if so how much....</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>P.D Ndlovu: </span><span>Indeed a great Gospel group based in Bulawayo...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>gizmo: </span><span>from a business point of view would you like to see the zim dan...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>Simbarashe Fulukia: </span><span>Nice read.  Long live the EMPRESS SOUKAINA,CITIZEN OF THE WORLD...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>al smith: </span><span>where is the secret dinner taking place?...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>Tawanda Mashava: </span><span>Thank you Teurai, I would also add Mawuyu (Baobab), sometimes c...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>mutowembwa: </span><span>Todawo haitodiwe kuDubai hapana kana munhu wekwo anoziwa zvemag...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>Dimitri: </span><span>I appreciate the positive nature of the article but if you woul...</span></div><div class='vsrc_div' style='height:55px;padding:2px 0px 2px 0px;'><span>Brendon: </span><span>Nice article but please give Dividing the Element the recogniti...</span></div>			</div>
		</div>
		<script type="text/javascript" src="http://www.zimbojam.com/wp-content/plugins/vertical-scroll-recent-comments/vertical-scroll-recent-comments.js"></script>
		<script type="text/javascript">
		var vsrc_array	= new Array();
		var vsrc_obj	= '';
		var vsrc_scrollPos 	= '';
		var vsrc_numScrolls	= '';
		var vsrc_heightOfElm = '59';
		var vsrc_numberOfElm = '1';
		var vsrc_speed 		= '7';
        var vsrc_waitseconds = '2';
		var vsrc_scrollOn 	= 'true';
		function vsrc_createscroll() 
		{
			vsrc_array[0] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>Arthur: </span><span><a href=\'http://www.zimbojam.com/movement-lights-ngz/#comment-490\'>Is there an entrance fee and if so how much. ...</a></span></div>'; vsrc_array[1] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>P.D Ndlovu: </span><span><a href=\'http://www.zimbojam.com/vocal-ex-drop-second-album/#comment-489\'>Indeed a great Gospel group based in Bulawayo ...</a></span></div>'; vsrc_array[2] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>gizmo: </span><span><a href=\'http://www.zimbojam.com/hifa-plays-dumb-zimdancehall/#comment-487\'>from a business point of view would you like to see the zim dan ...</a></span></div>'; vsrc_array[3] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>Simbarashe Fulukia: </span><span><a href=\'http://www.zimbojam.com/afrikera-opens-hub-central-harare/#comment-486\'>Nice read.  Long live the EMPRESS SOUKAINA,CITIZEN OF THE WORLD ...</a></span></div>'; vsrc_array[4] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>al smith: </span><span><a href=\'http://www.zimbojam.com/secret-dinner-returns-tapaz-showdown/#comment-485\'>where is the secret dinner taking place? ...</a></span></div>'; vsrc_array[5] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>Tawanda Mashava: </span><span><a href=\'http://www.zimbojam.com/5-zimbabwean-foods-will-help-supercharge-health-fitnessjourney/#comment-484\'>Thank you Teurai, I would also add Mawuyu (Baobab), sometimes c ...</a></span></div>'; vsrc_array[6] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>mutowembwa: </span><span><a href=\'http://www.zimbojam.com/jah-love-judgement-yard-split-dubai/#comment-481\'>Todawo haitodiwe kuDubai hapana kana munhu wekwo anoziwa zvemag ...</a></span></div>'; vsrc_array[7] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>Dimitri: </span><span><a href=\'http://www.zimbojam.com/rock-music-divides-elements/#comment-480\'>I appreciate the positive nature of the article but if you woul ...</a></span></div>'; vsrc_array[8] = '<div class=\'vsrc_div\' style=\'height:55px;padding:2px 0px 2px 0px;\'><span>Brendon: </span><span><a href=\'http://www.zimbojam.com/rock-music-divides-elements/#comment-479\'>Nice article but please give Dividing the Element the recogniti ...</a></span></div>'; 			vsrc_obj = document.getElementById('vsrc_Holder');
			vsrc_obj.style.height = (vsrc_numberOfElm * vsrc_heightOfElm) + 'px';
			vsrc_content();
		}
		</script>
		<script type="text/javascript">
		vsrc_createscroll();
		</script>
		</div>
<!-- Recently widget v1.0.2 [regular] -->
<div id="recently-2" class="widget recently">
<h3 class="widget-title">New Stories</h3>                <script type="text/javascript">//<![CDATA[
					// jQuery is available, so proceed
					if ( window.jQuery ) {
						
						jQuery(document).ready(function($){
							$.get('http://www.zimbojam.com/wp-admin/admin-ajax.php', {
								action: 'get_recently',
								widget_id: '2'
							}, function(data){
								$('#recently-2').append(data);
							});
						});
					
					} else { // jQuery is not defined
						if ( window.console && window.console.log )
							window.console.log('Recently: jQuery is not defined!');						
					}
                //]]></script>
                </div>
<!-- End Recently Plugin v1.0.2 -->
<div id="archives-2" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.zimbojam.com/2017/05/'> May 2017 </option>
	<option value='http://www.zimbojam.com/2017/04/'> April 2017 </option>
	<option value='http://www.zimbojam.com/2017/03/'> March 2017 </option>
	<option value='http://www.zimbojam.com/2017/02/'> February 2017 </option>
	<option value='http://www.zimbojam.com/2017/01/'> January 2017 </option>
	<option value='http://www.zimbojam.com/2016/12/'> December 2016 </option>
	<option value='http://www.zimbojam.com/2016/11/'> November 2016 </option>
	<option value='http://www.zimbojam.com/2016/10/'> October 2016 </option>
	<option value='http://www.zimbojam.com/2016/09/'> September 2016 </option>
	<option value='http://www.zimbojam.com/2016/08/'> August 2016 </option>
	<option value='http://www.zimbojam.com/2016/07/'> July 2016 </option>
	<option value='http://www.zimbojam.com/2016/06/'> June 2016 </option>
	<option value='http://www.zimbojam.com/2016/05/'> May 2016 </option>
	<option value='http://www.zimbojam.com/2016/04/'> April 2016 </option>
	<option value='http://www.zimbojam.com/2016/03/'> March 2016 </option>
	<option value='http://www.zimbojam.com/2016/02/'> February 2016 </option>
	<option value='http://www.zimbojam.com/2016/01/'> January 2016 </option>
	<option value='http://www.zimbojam.com/2015/12/'> December 2015 </option>
	<option value='http://www.zimbojam.com/2015/11/'> November 2015 </option>
	<option value='http://www.zimbojam.com/2015/10/'> October 2015 </option>
	<option value='http://www.zimbojam.com/2015/09/'> September 2015 </option>
	<option value='http://www.zimbojam.com/2015/08/'> August 2015 </option>
	<option value='http://www.zimbojam.com/2015/07/'> July 2015 </option>
	<option value='http://www.zimbojam.com/2015/06/'> June 2015 </option>
	<option value='http://www.zimbojam.com/2015/05/'> May 2015 </option>
	<option value='http://www.zimbojam.com/2015/04/'> April 2015 </option>
	<option value='http://www.zimbojam.com/2015/03/'> March 2015 </option>
	<option value='http://www.zimbojam.com/2015/02/'> February 2015 </option>
	<option value='http://www.zimbojam.com/2015/01/'> January 2015 </option>
	<option value='http://www.zimbojam.com/2014/12/'> December 2014 </option>
	<option value='http://www.zimbojam.com/2014/11/'> November 2014 </option>
	<option value='http://www.zimbojam.com/2014/10/'> October 2014 </option>
	<option value='http://www.zimbojam.com/2014/09/'> September 2014 </option>
	<option value='http://www.zimbojam.com/2014/08/'> August 2014 </option>
	<option value='http://www.zimbojam.com/2014/07/'> July 2014 </option>
	<option value='http://www.zimbojam.com/2014/06/'> June 2014 </option>
	<option value='http://www.zimbojam.com/2014/05/'> May 2014 </option>
	<option value='http://www.zimbojam.com/2014/04/'> April 2014 </option>
	<option value='http://www.zimbojam.com/2014/03/'> March 2014 </option>
	<option value='http://www.zimbojam.com/2014/02/'> February 2014 </option>
	<option value='http://www.zimbojam.com/2014/01/'> January 2014 </option>
	<option value='http://www.zimbojam.com/2013/12/'> December 2013 </option>
	<option value='http://www.zimbojam.com/2013/11/'> November 2013 </option>
	<option value='http://www.zimbojam.com/2013/10/'> October 2013 </option>
	<option value='http://www.zimbojam.com/2013/09/'> September 2013 </option>
	<option value='http://www.zimbojam.com/2013/08/'> August 2013 </option>
	<option value='http://www.zimbojam.com/2013/07/'> July 2013 </option>
	<option value='http://www.zimbojam.com/2013/06/'> June 2013 </option>
	<option value='http://www.zimbojam.com/2013/05/'> May 2013 </option>
	<option value='http://www.zimbojam.com/2013/04/'> April 2013 </option>
	<option value='http://www.zimbojam.com/2013/03/'> March 2013 </option>
	<option value='http://www.zimbojam.com/2013/02/'> February 2013 </option>
	<option value='http://www.zimbojam.com/2013/01/'> January 2013 </option>
	<option value='http://www.zimbojam.com/2012/12/'> December 2012 </option>
	<option value='http://www.zimbojam.com/2012/11/'> November 2012 </option>
	<option value='http://www.zimbojam.com/2012/10/'> October 2012 </option>
	<option value='http://www.zimbojam.com/2012/09/'> September 2012 </option>
	<option value='http://www.zimbojam.com/2012/08/'> August 2012 </option>
	<option value='http://www.zimbojam.com/2012/07/'> July 2012 </option>
	<option value='http://www.zimbojam.com/2012/06/'> June 2012 </option>
	<option value='http://www.zimbojam.com/2012/05/'> May 2012 </option>
	<option value='http://www.zimbojam.com/2012/04/'> April 2012 </option>
	<option value='http://www.zimbojam.com/2012/03/'> March 2012 </option>
	<option value='http://www.zimbojam.com/2012/02/'> February 2012 </option>
	<option value='http://www.zimbojam.com/2012/01/'> January 2012 </option>
	<option value='http://www.zimbojam.com/2011/12/'> December 2011 </option>
	<option value='http://www.zimbojam.com/2011/11/'> November 2011 </option>
	<option value='http://www.zimbojam.com/2011/10/'> October 2011 </option>
	<option value='http://www.zimbojam.com/2011/09/'> September 2011 </option>
	<option value='http://www.zimbojam.com/2011/08/'> August 2011 </option>
	<option value='http://www.zimbojam.com/2011/07/'> July 2011 </option>
	<option value='http://www.zimbojam.com/2011/06/'> June 2011 </option>
	<option value='http://www.zimbojam.com/2011/05/'> May 2011 </option>
	<option value='http://www.zimbojam.com/2011/04/'> April 2011 </option>
	<option value='http://www.zimbojam.com/2011/03/'> March 2011 </option>
	<option value='http://www.zimbojam.com/2011/02/'> February 2011 </option>
	<option value='http://www.zimbojam.com/2011/01/'> January 2011 </option>
	<option value='http://www.zimbojam.com/2010/12/'> December 2010 </option>
	<option value='http://www.zimbojam.com/2010/11/'> November 2010 </option>
	<option value='http://www.zimbojam.com/2010/10/'> October 2010 </option>
	<option value='http://www.zimbojam.com/2010/09/'> September 2010 </option>
	<option value='http://www.zimbojam.com/2010/08/'> August 2010 </option>
	<option value='http://www.zimbojam.com/2010/07/'> July 2010 </option>
	<option value='http://www.zimbojam.com/2010/06/'> June 2010 </option>
	<option value='http://www.zimbojam.com/2010/05/'> May 2010 </option>
	<option value='http://www.zimbojam.com/2010/04/'> April 2010 </option>
	<option value='http://www.zimbojam.com/2010/03/'> March 2010 </option>
	<option value='http://www.zimbojam.com/2010/02/'> February 2010 </option>
	<option value='http://www.zimbojam.com/2010/01/'> January 2010 </option>
	<option value='http://www.zimbojam.com/2009/12/'> December 2009 </option>
	<option value='http://www.zimbojam.com/2009/11/'> November 2009 </option>
	<option value='http://www.zimbojam.com/2009/10/'> October 2009 </option>
	<option value='http://www.zimbojam.com/2009/09/'> September 2009 </option>
	<option value='http://www.zimbojam.com/2009/08/'> August 2009 </option>
	<option value='http://www.zimbojam.com/2009/07/'> July 2009 </option>
	<option value='http://www.zimbojam.com/2009/06/'> June 2009 </option>
	<option value='http://www.zimbojam.com/2009/05/'> May 2009 </option>
	<option value='http://www.zimbojam.com/2009/04/'> April 2009 </option>
	<option value='http://www.zimbojam.com/2009/03/'> March 2009 </option>
	<option value='http://www.zimbojam.com/2009/02/'> February 2009 </option>
	<option value='http://www.zimbojam.com/2009/01/'> January 2009 </option>
	<option value='http://www.zimbojam.com/2008/12/'> December 2008 </option>
	<option value='http://www.zimbojam.com/2008/11/'> November 2008 </option>
	<option value='http://www.zimbojam.com/2008/10/'> October 2008 </option>

		</select>
		</div>			</div>
		</aside><!-- .page-sidebar -->				</div>			

		</div><!-- #container -->

	</div><!-- #main  -->

	
<footer class="site-footer" id="site-footer" itemscope itemtype="http://schema.org/WPFooter">

					<div class="footer-sidebar clearfix" itemscope itemtype="http://schema.org/WPSideBar">
				<div class="inner">
				<div class="vc_row wpb_row">
											<div class="vc_col-sm-3">
							<div class="widget-area">
								<div id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">About Zimbo Jam</h3><div class="menu-about-zimbo-jam-container"><ul id="menu-about-zimbo-jam" class="menu"><li id="menu-item-19419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19419"><a href="http://www.zimbojam.com/about/">About Us</a></li>
<li id="menu-item-20853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20853"><a href="http://www.zimbojam.com/awards/">Awards &#038; Honours</a></li>
<li id="menu-item-20848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20848"><a href="http://www.zimbojam.com/contributors/">Contributors</a></li>
<li id="menu-item-19418" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19418"><a href="http://www.zimbojam.com/privacy/">Privacy Policy</a></li>
<li id="menu-item-19417" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19417"><a href="http://www.zimbojam.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-23087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23087"><a href="http://www.zimbojam.com/contact/">Send us your story</a></li>
<li id="menu-item-19416" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19416"><a href="http://www.zimbojam.com/contact/">Contact Us</a></li>
</ul></div></div>							</div>
						</div>
					
											<div class="vc_col-sm-3">
							<div class="widget-area">
								<div id="nav_menu-3" class="widget widget_nav_menu"><h3 class="widget-title">Social Media Profiles</h3><div class="menu-social-media-profiles-container"><ul id="menu-social-media-profiles" class="menu"><li id="menu-item-19424" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19424"><a href="https://www.twitter.com/zimbojam">Twitter</a></li>
<li id="menu-item-19423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19423"><a href="https://www.facebook.com/zimbojam">Facebook</a></li>
<li id="menu-item-19425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19425"><a href="https://www.instagram.com/zimbojam">Instagram</a></li>
<li id="menu-item-19426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19426"><a href="https://www.youtube.com/zimbojam">YouTube</a></li>
</ul></div></div>							</div>	
						</div>
					
					
											<div class="vc_col-sm-3">
							<div class="widget-area">
								<div id="newsletterwidget-2" class="widget widget_newsletterwidget"><h3 class="widget-title">Subscribe to Our Newsletter</h3>Receive the Zimbo Jam newsletter and stay up to date with lifestyle, arts & culture in Zimbabwe & its Diaspora.<div class="tnp tnp-widget"><form method="post" action="http://www.zimbojam.com/?na=s" onsubmit="return newsletter_check(this)">

<input type="hidden" name="nr" value="widget">
<div class="tnp-field tnp-field-firstname"><label>Name</label><input class="tnp-firstname" type="text" name="nn" required></div>
<div class="tnp-field tnp-field-lastname"><label>Last name</label><input class="tnp-lastname" type="text" name="ns" ></div>
<div class="tnp-field tnp-field-email"><label>Email</label><input class="tnp-email" type="email" name="ne" required></div>
<div class="tnp-field tnp-field-button"><input class="tnp-submit" type="submit" value="Subscribe">
</div>
</form>
</div>
</div>							</div>	
						</div>
									</div><!-- .vc_row -->
				</div><!-- .inner -->
			</div><!-- .footer-sidebar -->
			
		
			
			<div class="site-info" itemscope itemtype="http://schema.org/WPSideBar"> 
				<div class="inner">
					<div id="text-3" class="widget widget_text">			<div class="textwidget"><div align="center">Copyright &copy; Zimbo Jam and Zimbo Jam Archives. All rights reserved.<br/>Zimbo Jam (Est. 2008), incorporating Itsbho.com (Est. 2004) documents, celebrates and challenges Zimbabwean society, arts & culture.<br/><br/></div></div>
		</div>				</div>
			</div>	
			
		
</footer><!-- .site-footer -->	
	<nav id="mobile-site-navigation">
		<ul id="menu-zimbo-jam-main-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19396"><a href="http://www.zimbojam.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19445"><a href="http://www.zimbojam.com/category/society/">Society</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22441"><a href="http://www.zimbojam.com/category/society/young-shakers/">Young Shakers</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20819"><a href="http://www.zimbojam.com/category/society/opinion-advice/">Opinion &#038; Advice</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19446"><a href="http://www.zimbojam.com/category/society/travel-stories/">Travel</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19447"><a href="http://www.zimbojam.com/category/society/trends/">Trends</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19397"><a href="http://www.zimbojam.com/social-watch/">Social Media Watch</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-19434"><a href="http://www.zimbojam.com/category/arts/">Arts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19439"><a href="http://www.zimbojam.com/category/arts/theatre/">Theatre &#038; Comedy</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-19438"><a href="http://www.zimbojam.com/category/arts/music/">Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19436"><a href="http://www.zimbojam.com/category/arts/dance/">Dance</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19435"><a href="http://www.zimbojam.com/category/arts/books/">Books</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19437"><a href="http://www.zimbojam.com/category/arts/film-tv/">Film &#038; TV</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19440"><a href="http://www.zimbojam.com/category/arts/visual-arts/">Visual Arts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19441"><a href="http://www.zimbojam.com/category/culture/">Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19442"><a href="http://www.zimbojam.com/category/culture/fashion/">Fashion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19443"><a href="http://www.zimbojam.com/category/culture/fashion-pics/">Fashion Pics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19444"><a href="http://www.zimbojam.com/category/culture/pageants-modelling/">Pageants &#038; Modelling</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19448"><a href="http://www.zimbojam.com/category/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19449"><a href="http://www.zimbojam.com/category/multimedia/pictures/">In Pictures</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19450"><a href="http://www.zimbojam.com/category/multimedia/video/">In Video</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22702"><a href="http://www.zimbojam.com/jam-tv/">Jam TV</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19467"><a href="#">Community</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19473"><a href="http://www.zimbojam.com/notebook/">Notebook</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19453"><a href="http://www.zimbojam.com/noticeboard/">Noticeboard</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19456"><a href="http://www.zimbojam.com/newsletter/">Newsletter</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19991"><a href="http://www.zimbojam.com/gigs/">Gig Guide</a></li>
</ul>	</nav><!-- #mobile-site-navigation -->
	
</div><!-- #wrapper -->


<a href="#top" class="scrollToTop"><i class="fa fa-angle-up"></i></a>		
        <script>window.init_zoombox_settings = {
                settings_zoom_doNotGoBeyond1X: 'off'
                , design_skin: 'skin-nebula'
                , settings_enableSwipe: 'off'
                , settings_enableSwipeOnDesktop: 'off'
                , settings_galleryMenu: 'dock'
                , settings_useImageTag: 'on'
                , settings_paddingHorizontal: '100'
                , settings_paddingVertical: '100'
                , settings_disablezoom: 'off'
                , settings_transition: 'fade'
                , settings_transition_out: 'fade'
                , settings_transition_gallery: 'slide'
                , settings_disableSocial: 'on'
                , settings_zoom_use_multi_dimension: 'on'
                ,videoplayer_settings:{
                    zoombox_video_autoplay: "off"
                    ,design_skin: "skin_bigplay"
            }
            };
        </script>	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Content is protected from copying.</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://www.zimbojam.com/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://www.zimbojam.com/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://www.zimbojam.com/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://www.zimbojam.com/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>
	<div style="display:none">
	<div class="grofile-hash-map-935a3cd456b55a80634b58040171e851">
	</div>
	<div class="grofile-hash-map-2a73590e7555ea66dfe7600fca24fc54">
	</div>
	<div class="grofile-hash-map-03dfab0570638120d60159b4d2b5abd1">
	</div>
	<div class="grofile-hash-map-90bcf5b3d4132a8f1908dc705c649836">
	</div>
	<div class="grofile-hash-map-18735552b2147f3d64552449853bcabe">
	</div>
	<div class="grofile-hash-map-4dea8580754f29e02c090926c91eafe8">
	</div>
	<div class="grofile-hash-map-c635d8297cfa4da8ff737dd20baec998">
	</div>
	<div class="grofile-hash-map-3419813855cbf60e52dc70196b2a1c65">
	</div>
	<div class="grofile-hash-map-acc2324ef22416a69e35879b0257d120">
	</div>
	<div class="grofile-hash-map-8bd103e18973c9ef8d4e2dde6559bed9">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.zimbojam.com\/team-legacy-zw-championing-zim-hip-hop-movement\/":25199};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/team-legacy-zw-championing-zim-hip-hop-movement/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://www.zimbojam.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='wp_pro_add_style-css'  href='http://www.zimbojam.com/wp-content/plugins/wppas/templates/css/wppas.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wppas_php_style-css'  href='http://www.zimbojam.com/wp-admin/admin-ajax.php?action=wppas_php_style&#038;ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.zimbojam.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.5.1'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201719'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"9","round_shares":"","animate_shares":"0","dynamic_buttons":"0","share_url":"http:\/\/www.zimbojam.com\/team-legacy-zw-championing-zim-hip-hop-movement\/","title":"Team+Legacy+Zw%3A+Championing+the+Zim+Hip+Hop+movement","image":"http:\/\/www.zimbojam.com\/wp-content\/uploads\/2017\/05\/MC-CHITA-in-action-at-HIFA-2017.jpg","desc":"Former U.S President Barrack Obama once remarked, \u201cThe thing about hip-hop today is it is smart, it is insightful. The way they can communicate a complex message in a very short space is remarkable.\u201d\r\n\r\nWhat is \u2026","hashtag":"zimbojam","subscribe":"link","subscribe_url":"http:\/\/www.zimbojam.com\/newsletter\/","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.3.4'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/jquery/ui/effect-shake.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/themes/bitz/js/init.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/themes/bitz/js/sticky-header-smart.js?ver=4.6.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var objectL10n = {"title":"Menu"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/themes/bitz/js/jquery.mmenu.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/themes/bitz/js/theia-sticky-sidebar.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/comment-reply.min.js?ver=4.6.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/newsletter/subscription/validate.js?ver=4.8.0'></script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-includes/js/wp-embed.min.js?ver=4.6.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wppas_ajax_script = {"ajaxurl":"http:\/\/www.zimbojam.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/wppas/templates/js/wppas.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.zimbojam.com/?ai1ec_render_js=common_frontend&#038;is_backend=false&#038;ver=2.5.13'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.4.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"b31a1516f0","ajaxurl":"http:\/\/www.zimbojam.com\/wp-admin\/admin-ajax.php","enlarge":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.zimbojam.com/wp-content/plugins/captcha/js/front_end_script.js?ver=4.6.5'></script>
        <div id="newsletter-popup-overlay"></div>
        <div id="newsletter-popup-container">
            <div id="newsletter-popup"><img id="newsletter-close" src="http://www.zimbojam.com/wp-content/plugins/newsletter-popup/images/close.png">
                <iframe id="newsletter-iframe" data-src="http://www.zimbojam.com/wp-content/plugins/newsletter-popup/iframe.php"></iframe></div>
        </div>
        <script>
            function newsletter_set_cookie(name, value, time) {
                var e = new Date();
                e.setTime(e.getTime() + time * 24 * 60 * 60 * 1000);
                document.cookie = name + "=" + value + "; expires=" + e.toGMTString() + "; path=/";
            }
            function newsletter_get_cookie(name, def) {
                var cs = document.cookie.toString().split('; ');
                var c, n, v;
                for (var i = 0; i < cs.length; i++) {
                    c = cs[i].split("=");
                    n = c[0];
                    v = c[1];
                    if (n == name)
                        return v;
                }
                return def;
            }
            jQuery(document).ready(function () {

                jQuery("#newsletter-close").click(
                        function () {
                            jQuery('#newsletter-popup-overlay').fadeOut('fast');
                            jQuery('#newsletter-popup-container').hide();
                        });

                jQuery("#newsletter-popup-overlay").click(
                        function () {
                            jQuery(this).fadeOut('fast');
                            jQuery('#newsletter-popup-container').hide();
                        });

                            if (newsletter_get_cookie("newsletter", null) == null) {
                        var newsletter_popup = parseInt(newsletter_get_cookie("newsletter_popup", 0));
                        newsletter_set_cookie("newsletter_popup", newsletter_popup + 1, 20);
                        if (newsletter_popup == 1) {
                            jQuery('#newsletter-iframe').attr("src", jQuery('#newsletter-iframe').attr("data-src"));
                            setTimeout(newsletter_popup_open,
            10000);
                        }
                    }
                    });

            function newsletter_popup_open() {
                jQuery('#newsletter-iframe').attr("src", jQuery('#newsletter-iframe').attr("data-src"));
                //jQuery('#overlay').css('height', $(document).height());
                jQuery('#newsletter-popup-overlay').fadeIn('fast');
                var windowW = jQuery(window).width();
                var windowH = jQuery(window).height();
                //var modalW = jQuery('#box').width();
                //var modalH = jQuery('#box').height();
                /*
                 jQuery('#box').css({
                 "top": ((windowH - modalH) / 2 + $(document).scrollTop()) + "px",
                 "left": ((windowW - modalW) / 2) + "px"
                 });
                 */
                jQuery('#newsletter-popup-container').fadeIn('slow');
                return false;
            }
        </script>
        <script type='text/javascript' src='http://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.1',blog:'117573896',post:'25199',tz:'2',srv:'www.zimbojam.com'} ]);
	_stq.push([ 'clickTrackerInit', '117573896', '25199' ]);
</script>
<style type="text/css"></style><script type="text/javascript">var essb_clicked_lovethis = false; var essb_love_you_message_thanks = "Thank you for loving this."; var essb_love_you_message_loved = "You already love this today."; var essb_lovethis = function(oInstance) { if (essb_clicked_lovethis) { alert(essb_love_you_message_loved); return; } var element = jQuery('.essb_'+oInstance); if (!element.length) { return; } var instance_post_id = jQuery(element).attr("data-essb-postid") || ""; var cookie_set = essb_get_lovecookie("essb_love_"+instance_post_id); if (cookie_set) { alert(essb_love_you_message_loved); return; } if (typeof(essb_settings) != "undefined") { jQuery.post(essb_settings.ajax_url, { 'action': 'essb_love_action', 'post_id': instance_post_id, 'service': 'love', 'nonce': essb_settings.essb3_nonce }, function (data) { if (data) { alert(essb_love_you_message_thanks); }},'json'); } essb_tracking_only('', 'love', oInstance, true); }; var essb_get_lovecookie = function(name) { var value = "; " + document.cookie; var parts = value.split("; " + name + "="); if (parts.length == 2) return parts.pop().split(";").shift(); };var essb_window = function(oUrl, oService, oInstance) { var element = jQuery('.essb_'+oInstance); var instance_post_id = jQuery(element).attr("data-essb-postid") || ""; var instance_position = jQuery(element).attr("data-essb-position") || ""; var wnd; var w = 800 ; var h = 500; if (oService == "twitter") { w = 500; h= 300; } var left = (screen.width/2)-(w/2); var top = (screen.height/2)-(h/2); if (oService == "twitter") { wnd = window.open( oUrl, "essb_share_window", "height=300,width=500,resizable=1,scrollbars=yes,top="+top+",left="+left ); } else { wnd = window.open( oUrl, "essb_share_window", "height=500,width=800,resizable=1,scrollbars=yes,top="+top+",left="+left ); } if (typeof(essb_settings) != "undefined") { if (essb_settings.essb3_stats) { if (typeof(essb_handle_stats) != "undefined") { essb_handle_stats(oService, instance_post_id, oInstance); } } if (essb_settings.essb3_ga) { essb_ga_tracking(oService, oUrl, instance_position); } } essb_self_postcount(oService, instance_post_id); var pollTimer = window.setInterval(function() { if (wnd.closed !== false) { window.clearInterval(pollTimer); essb_smart_onclose_events(oService, instance_post_id); } }, 200); }; var essb_self_postcount = function(oService, oCountID) { if (typeof(essb_settings) != "undefined") { oCountID = String(oCountID); jQuery.post(essb_settings.ajax_url, { 'action': 'essb_self_postcount', 'post_id': oCountID, 'service': oService, 'nonce': essb_settings.essb3_nonce }, function (data) { if (data) { }},'json'); } }; var essb_smart_onclose_events = function(oService, oPostID) { if (typeof (essbasc_popup_show) == 'function') { essbasc_popup_show(); } if (typeof essb_acs_code == 'function') { essb_acs_code(oService, oPostID); } }; var essb_tracking_only = function(oUrl, oService, oInstance, oAfterShare) { var element = jQuery('.essb_'+oInstance); if (oUrl == "") { oUrl = document.URL; } var instance_post_id = jQuery(element).attr("data-essb-postid") || ""; var instance_position = jQuery(element).attr("data-essb-position") || ""; if (typeof(essb_settings) != "undefined") { if (essb_settings.essb3_stats) { if (typeof(essb_handle_stats) != "undefined") { essb_handle_stats(oService, instance_post_id, oInstance); } } if (essb_settings.essb3_ga) { essb_ga_tracking(oService, oUrl, instance_position); } } essb_self_postcount(oService, instance_post_id); if (oAfterShare) { essb_smart_onclose_events(oService, instance_post_id); } }; var essb_pinterest_picker = function(oInstance) { essb_tracking_only('', 'pinterest', oInstance); var e=document.createElement('script'); e.setAttribute('type','text/javascript'); e.setAttribute('charset','UTF-8'); e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e); };</script></body>
</html>